Plesk üzerinden farklı php versiyon çalıştırma

Uzun bir aradan sonra Plesk üzerinden farklı php versiyon çalıştırma işlemini kısaca anlatacağım.

Neden gereksinim duyalım?

Laravel 5+ kurulum yapmak istediğiniz server üzerinde varsayılan tanımlanan php versiyonunuzu kontrol eder. Eğer Larave 5.6 + versiyon kullanmak isterseniz sizden php 5.3 yüklü olmasını ister. Bu gibi durumlarda php dizinlerinden istediğiniz versiyon dizininden çağırarak çalıştırabilirsiniz.

Farklı PHP versiyonunu set edebilirmiyim?

Elbette plesk üzerinden farklı bir php versiyonunu kendinize göre set edebilirsiniz. Fakat hosting kullanıyorsanız bunu sadece root/administrator sağlayabilir.

Plesk üzerinden farklı php versiyon çalıştırma

Aşağıda size plesk üzerinden php 7.1 yolunu verdim. PHP versiyonuna göre yolunuz değişebilir. 5.3 / 7.2 gibi.


/opt/plesk/php/7.1/bin/php